Home > Tutorials and Resources > Image Editing with Gimp

Image Editing with Gimp

By B Lingafelter          graphics

You don't have to buy and learn Photoshop to edit your digital photos. Gimp (GNU Image Manipulation Program) is an alternative free, open-source application that is almost as powerful as Photoshop, and is available for Windows, Mac, and Linux platforms.

Download the current version of Gimp at http://www.gimp.org/. Click the Download button.

Download Gimp screenshot
Note: The download server does allow you to choose a specific version and installer for your platform, but can be confusing. At this point, the easiest way to grab the executable (.exe) file for the most current stable Gimp version for Windows is shown in the screenshot above.

To run Gimp from a portable drive, pick up Gimp Portable (provided by PortableApps.com).

The Backstory

Bitmapped Graphics

Digital photos are bitmapped graphics. This means they are composed of many (sometimes millions) colored squares, called pixels. Unlike vector graphics, that have handles used to resize them, bitmapped graphics require special tools to select and manipulate groups of pixels.

zoomed in segment of arc showing pixels
Zoomed in segment of an arc, shows individual square pixels that make up the image.

Some Terminology

JPEG
Compressed file format for photos that throws away unwanted pixels. More compression = smaller file size and lower quality
TIFF
Uncompressed format – retains all pixels but file sizes can be very large (not suitable for the Web)
Resolution
Number of pixels per inch (ppi) – 72 or 96ppi for Web and on-screen display; 300 or 600ppi for print
Resize (scale)
Reduce physical dimensions – Enlarging does not generally yield satisfactory results as it requires application to “make up” pixels out of thin air
Crop
Cut off edges you don’t want
Transform
Flip or rotate an image
Brightness
Overall lightness or darkness of all the colors in an image
Contrast
Degree of difference between the lightest and darkest color values in an image
Hue
Colorcast of an image
Saturation
Color purity – increase to reduce gray and intensify color

Configure Gimp for single window display

By default, the Gimp file window, panels and toolbars float independently on the desktop. To dock them in a single application window, choose Windows > Single-Window mode.

Saving/exporting images in Gimp

Gimp's native file format is XCF. Similar to PhotoShop's PSD format, XCF is a very useful format because it stores all information about an image except "undo" information. Images opened in Gimp are automatically saved in XCF format. This means the Save and Save As… commands assume you want layers, channels, and other information to be saved in XCF format so the file can be easily re-opened and edited in Gimp.

To convert an opened image to a specific file format (like GIF, JPEG, PNG, etc.):

  1. Choose File > Export As… command
  2. Select location where you want image saved
  3. Click + button Select File_Type and choose desired file format
  4. Click Export button.

Gimp Export Image dialog box

Screenshots of dialog boxes for most common file formats shown below. Click Help button in any dialog box for more information about format options.

Export Image as JPEG
Export Image as PNG
Export Image as GIF

Image Editing Techniques

General instructions for some of the most common image editing techniques listed below. For more specific techniques and tutorials, review the Gimp Resources listed at the bottom of the page.

Crop an image

  1. Choose Tools > Transform > Crop
  2. Drag to select pixels you want to keep
  3. Drag center of selection to move it; drag a corner to adjust size
  4. Double-click inside selection to complete operation

Resize (scale) an image

Scale Image dialog box
  1. Choose Image > Scale Image
  2. Enter desired width or height (link icon indicates Gimp will adjust the other dimension to retain original proportions)
  3. Click Scale to complete operation

Adjust Levels

Adjust Levels dialog box
  1. Choose Colors > Levels
  2. Under the Input Levels, drag middle point (gamma) to adjust midtones, left point to adjust shadows, and right point to adjust highlights
  3. Click OK when finished to apply levels

Adjust Color Balance

For color corrections: reduce/intensify color, and remove color casts.

Adjust Color Balance dialog box
  1. Choose Colors > Color Balance
  2. Select Midtones option
  3. Drag sliders to adjust color cast
  4. Click OK when finished to apply corrections

Sharpen an image

To correct out-of-focus images and apply sharpening correction to digital images.

Unsharp Mask filter dialog box
  1. Choose Filters > Enhance > Unsharp Mask
  2. Adjust Radius, Amount, and Threshold as needed
    • Radius - how many pixels on either side of an edge will be affected by sharpening
    • Amount - strength of sharpening
    • Threshold - the minimum difference in pixel values that indicates an edge where sharpen must be applied
  3. Click OK to apply sharpening

Flip, Rotate, and Straighten an image

  1. Choose Image > Transform
  2. As appropriate for the image, choose Flip Horizontally/Vertically, Rotate 90° clockwise/counter-clockwise, or Rotate 180°
  3. For free-form rotation (amount and direction), select Rotate tool in toolbox (Shift+R)
  4. Click in image with Rotate tool
  5. In Rotate dialog box, use Angle incrementing buttons or slider to adjust amount of rotation as necessary to straighten image

Remove Red-Eye

  1. Select Zoom tool and drag around one pair of eyes
  2. Select Ellipse Select Tool and drag to select red pixels in one eye
  3. Point inside selection and drag four-headed arrow to move selection, or drag a corner to adjust size
    Ellipse Select tool
  4. To select the other eye, press Shift while dragging to select red pixels in other eye (adds another selection)
  5. Release Shift and adjust size
  6. Choose Filters > Enhance > Red Eye Removal
    Red Eye Removal dialog box
  7. Adjust Threshold slider and click OK to apply
  8. Choose View > Zoom > 1:1 (100%)
  9. If necessary, repeat steps to correct another pair of eyes in this image

Gimp Resources